C++的STL中字符串string自带方法find查找

C++的STL中字符串string自带方法find查找

用法

1
2
3
string str = "abcd";
cout << str.find('a');
//返回的是下标的值而不是指针或是迭代器
1
2
3
4
5
6
7
string str = "abcd"
string sub = "cd"
if(str.find(sub)!=string::npos){
cout<<"找到了"<<endl;
}else{
cout<<"没有找到"<<endl;
}

要是没有找到,返回的是str::npos
注意,只有string的find方法是返回的下标,因为string是顺序索引,set,map,multiset,multimap都不是顺序索引的数据结构,所以返回的是迭代器。

样例一:L1-070 吃火锅 (15 分)

题目链接:

https://pintia.cn/problem-sets/994805046380707840/problems/1336215880692482053

chg.jpg

以上图片来自微信朋友圈:这种天气你有什么破事打电话给我基本没用。但是如果你说“吃火锅”,那就厉害了,我们的故事就开始了。

本题要求你实现一个程序,自动检查你朋友给你发来的信息里有没有 chi1 huo3 guo1

输入格式:

输入每行给出一句不超过 80 个字符的、以回车结尾的朋友信息,信息为非空字符串,仅包括字母、数字、空格、可见的半角标点符号。当读到某一行只有一个英文句点 . 时,输入结束,此行不算在朋友信息里。

输出格式:

首先在一行中输出朋友信息的总条数。然后对朋友的每一行信息,检查其中是否包含 chi1 huo3 guo1,并且统计这样厉害的信息有多少条。在第二行中首先输出第一次出现 chi1 huo3 guo1 的信息是第几条(从 1 开始计数),然后输出这类信息的总条数,其间以一个空格分隔。题目保证输出的所有数字不超过 100。

如果朋友从头到尾都没提 chi1 huo3 guo1 这个关键词,则在第二行输出一个表情 -_-#

输入样例 1:

1
2
3
4
5
6
Hello!
are you there?
wantta chi1 huo3 guo1?
that's so li hai le
our story begins from chi1 huo3 guo1 le
.

输出样例 1:

1
2
5
3 2

输入样例 2:

1
2
3
4
5
6
Hello!
are you there?
wantta qi huo3 guo1 chi1huo3guo1?
that's so li hai le
our story begins from ci1 huo4 guo2 le
.

输出样例 2:

1
2
5
-_-#

程序源代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
#include <bits/stdc++.h>
using namespace std;
int main()
{
int flag=0; //用来判断是否是第一次找到吃火锅
int cnt=0; //用来记录总行数
int count=0; //用来记录有多少个吃火锅
int firstp=0; //用来记录第一次出现吃火锅的位置
string cmp="chi1 huo3 guo1";
while (true)
{
string s;
s.clear();
getline(cin,s);
if(s.size()==1&&s=="."){
break;
}
string tmp =s;
if(tmp.find(cmp)!=string::npos){
if(flag==0) {
flag =1;
firstp = cnt+1;
}
count=count+1;
}
cnt=cnt+1;

}
if(count==0){
cout<<cnt<<endl;
cout<<"-_-#"<<endl;
} else{
cout<<cnt<<endl;
cout<<firstp<<" "<<count<<endl;
}

return 0;
}

参考资料

(18条消息) c++STL中的find()函数 有两种使用方法_我们不生产代码,只是代码的搬运工的博客-CSDN博客_c++中find函数的使用方法

https://pintia.cn/problem-sets/994805046380707840/problems/1336215880692482053